Heroku - Vendor Service Disruption

Incident Report for Zenput

Resolved

The incident we encountered with our vendor, Heroku, has been resolved.

All services are operational.
Posted Jun 11, 2025 - 05:34 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2025 - 03:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2025 - 00:53 UTC

Update

Services and task generation are operational. We will continue monitoring and provide an update once Heroku stops restarting servers across their fleet.
Posted Jun 11, 2025 - 00:38 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption. However, we are now seeing intermittent successful loads, and their frequency is increasing.
Posted Jun 10, 2025 - 23:34 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption. However, we are now seeing intermittent successful loads, and their frequency is increasing.
Posted Jun 10, 2025 - 22:31 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 10, 2025 - 22:31 UTC

Monitoring

Our vendor, Heroku, is still experiencing a service disruption. However, we are now seeing intermittent successful loads, and their frequency is increasing.

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Jun 10, 2025 - 22:02 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption.
We will post additional updates as they become available.
We apologize for this service disruption, we know that you rely on Zenput to manage operations every day, and we understand the impact this is having on your business.
Posted Jun 10, 2025 - 19:31 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption. We sincerely apologize for any disruptions to the Zenput service.

We will post additional updates as they become available.
Posted Jun 10, 2025 - 19:30 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption. We sincerely apologize for any disruptions on the Zenput service.
We will post additional updates as they become available.
Posted Jun 10, 2025 - 18:28 UTC

Update

Our vendor, Heroku, is still experiencing a service disruption.
We will post additional updates as they become available.
Posted Jun 10, 2025 - 16:51 UTC

Update

Our vendor, Heroku, is currently experiencing a service disruption.
We will post additional updates as they become available.
Posted Jun 10, 2025 - 15:42 UTC

Update

The Heroku service is experiencing an intermittent service disruption, which is currently being investigated. The Dashboard and Application Programming Interface (API) are failing intermittently.

We will send an additional update as soon as our vendor provides it.
Posted Jun 10, 2025 - 14:41 UTC

Update

The Heroku service is experiencing an intermittent service disruption, which is currently being investigated. Dashboard and Application Programming Interface (API) are failing intermittently.

We will send an additional update as soon as our vendor provides it.
Posted Jun 10, 2025 - 13:38 UTC

Update

The team has identified some network configuration issues on one of the servers within their Heroku environment, which could have triggered this issue. They are exploring this further and remain focused on providing a long-term solution for all affected customers.
Posted Jun 10, 2025 - 12:58 UTC

Update

The engineering team of our subprocessor is exploring whether any recent changes in the Heroku environment would have contributed to the issue. An attempted mitigation by disabling a single server did not produce the desired results, and further analysis is underway.

They are continuing the investigations with the provider.
Posted Jun 10, 2025 - 12:35 UTC

Update

We are continuing to monitor the service disruption that our subprocessor, Heroku, is experiencing. This is affecting platform access.

We will send an additional update in 2 hours or as soon as our vendor has an update.
Posted Jun 10, 2025 - 10:57 UTC

Identified

Our vendor, Heroku, is currently experiencing a service disruption.

We will send an additional update in 2 hours or as soon as our vendor has an update.
Posted Jun 10, 2025 - 08:46 UTC
This incident affected: Web Application, API, Task Generation, Reporting, Submission Processing, Labels Application, Mobile Application, and Temp Monitoring.