External Provider Infrastructure Service Degradation

Incident Report for Zenput

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:41 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 05:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 00:45 UTC

Update

At this time, we can confirm that application performance has stabilized. Our team is monitoring this closely
Posted Oct 20, 2025 - 23:03 UTC

Update

We are currently re-routing web traffic to the new, stable environment.

You will now be able to access the application login page directly at www.zenput.com.

Since we are serving data across regions to maintain stability, the application's performance will be slower than usual. Our immediate priority is functional access over optimal speed.

Zenput is now accessible. Our team will continue monitoring and will focus next on optimizing performance to return the platform to normal operating speeds.
Posted Oct 20, 2025 - 21:25 UTC

Update

Our Engineering team is actively working to shift affected services to alternate, unaffected providers to mitigate the external impact and restore full functionality as quickly as possible.
We will provide the next update shortly.
Posted Oct 20, 2025 - 19:04 UTC

Update

Our team has implemented a potential fix and is currently monitoring system performance to ensure stability. We’ll continue to observe the results closely and will provide another update once we confirm full resolution.

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 19:00 UTC

Update

We’re continuing to monitor the ongoing AWS outage impacting our hosting provider.

Background processes are still affected, including report generation, certain data imports, sending notifications, and image thumbnail creation, which may be slower than usual. AWS has begun rolling out a fix, and we’ll provide another update once we see further recovery or full resolution.

Our team continues to monitor the situation closely and will provide further updates.
Posted Oct 20, 2025 - 17:14 UTC

Update

We’re continuing to monitor the ongoing AWS outage impacting our hosting provider.

Background processes are still affected, including report generation, certain data imports, sending notifications, and image thumbnail creation, which may be slower than usual. AWS has begun rolling out a fix, and we’ll provide another update once we see further recovery or full resolution.

Our team continues to monitor the situation closely and will provide further updates.
Posted Oct 20, 2025 - 16:31 UTC

Update

We’re continuing to monitor the ongoing AWS outage impacting our hosting provider. AWS has begun rolling out a fix, and we’ll provide another update once we see further recovery or full resolution.

Most functionality remains stable, and response times are normal. Some background processes are still affected, including report generation, certain data imports, and image thumbnail creation, which may be slower than usual.

Our team continues to monitor the situation closely and will provide another update once all systems are confirmed to be fully operational.
Posted Oct 20, 2025 - 15:33 UTC

Update

We’re continuing to monitor the ongoing AWS outage impacting our hosting provider. AWS has begun rolling out a fix, and we’ll provide another update once we see further recovery or full resolution.

Most functionality remains stable and response times are normal. Report generation is still affected, and some background data imports have not yet resumed.

Our team continues to monitor the situation closely and will provide another update once all systems are confirmed to be fully operational.
Posted Oct 20, 2025 - 14:32 UTC

Update

We’re still seeing some impact from the broader AWS outage, which is affecting our hosting provider’s ability to scale resources. While this isn’t currently causing service interruptions, it may temporarily affect certain background processes, including report generation and data imports.

Temperature readings have fully caught up, and temperature monitoring functionality has been restored.

Our team continues to monitor the situation closely and will provide another update once all systems are confirmed to be fully operational.
Posted Oct 20, 2025 - 13:22 UTC

Update

AWS services are gradually recovering, and LoRa temperature readings are coming in again.
At this time, we don’t expect any data loss, and readings should continue to process as systems stabilize.

We’re keeping a close eye on performance and will update once everything is fully back to normal.
Posted Oct 20, 2025 - 12:08 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:06 UTC

Monitoring

We’re currently experiencing an issue due to an ongoing AWS outage, which is impacting our ability to process LoRa temperature readings and send SMS notifications. These are the symptoms identified so far, and our team is actively monitoring the situation while AWS works on restoring their service. We’ll share updates as soon as more information becomes available.
Posted Oct 20, 2025 - 07:00 UTC
This incident affected: Web Application, Reporting, Labels Application, Mobile Application and Notifications (Push, SMS (Text)).