Cloudflare Outage

Incident Report for Zenput

Resolved

This incident with Cloudfare has been resolved.
Posted Apr 23, 2026 - 04:51 UTC

Monitoring

We're aware of an incident with Cloudflare and are closely monitoring this issue.

Cloudflare has implemented a fix,
Posted Apr 23, 2026 - 04:11 UTC