We will provide updates on the incident: External Provider Infrastructure Service Degradation
Posted Oct 20, 2025 - 19:14 UTC
Update
Our Engineering team is actively working to shift affected services to alternate, unaffected providers to mitigate the external impact and restore full functionality as quickly as possible. We will provide the next update shortly.
Posted Oct 20, 2025 - 19:04 UTC
Monitoring
Our team has implemented a potential fix and is currently monitoring system performance to ensure stability. We’ll continue to observe the results closely and will provide another update once we confirm full resolution.
Thank you for your patience and understanding.
Posted Oct 20, 2025 - 19:00 UTC
Update
We're aware of an issue preventing some customers from logging in to the mobile and web apps. We are experiencing reduced performance, and users may notice slowness on pages and sporadic 500 error pages.
Our team is actively investigating and working to resolve this.
Posted Oct 20, 2025 - 17:15 UTC
Identified
We're aware of an issue preventing some customers from logging in to the mobile and web apps. We are experiencing reduced performance, and users may notice slowness on pages and sporadic 500 error pages.
Our team is actively investigating and working to resolve this.
Posted Oct 20, 2025 - 16:25 UTC
This incident affected: Web Application, API, Task Generation, Reporting, Submission Processing, Labels Application, Mobile Application, and Temp Monitoring.