Our vendor, Snowflake, implemented the fix for this issue and monitored the environment to confirm that service was restored.
Posted Jun 12, 2025 - 10:23 UTC
Update
Reporting systems are now operational.
We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 09:50 UTC
Monitoring
Our vendor, Snowflake, has implemented a fix for this issue. They are monitoring the environment until all services are functioning properly.
We apologize as reporting systems including reporting on Production Sheets are still unavailable.
We are closely monitoring the situation and we will provide updates as information becomes available.
Posted Jun 12, 2025 - 08:40 UTC
Update
The fix to the affected services from our vendor, Snowflake, has been successfully rolled out. They are closely monitoring key metrics to ensure full recovery across all services.
We apologize as reporting systems including reporting on Production Sheets are still unavailable.
We are continuously monitoring the situation and we will provide updates once information becomes available.
Posted Jun 12, 2025 - 08:04 UTC
Update
Our vendor, Snowflake, has rolled out a fix to the affected services and are seeing signs of recovery.
Reporting systems including reporting on Production Sheets, however, are still unavailable.
We are continuously monitoring the situation and we will provide updates once information becomes available.
Posted Jun 12, 2025 - 06:58 UTC
Update
Our vendor, Snowflake, is currently rolling out a fix to the affected services.
We apologize as our reporting systems, including reporting on Production Sheets are still unavailable.
We will continue to monitor the situation and provide updates as more information becomes available.
Posted Jun 12, 2025 - 06:00 UTC
Update
Our vendor, Snowflake, is still experiencing a service disruption and is currently developing and implementing a fix to restore services that affect our reporting systems.
We will provide additional updates as more information becomes available.
Posted Jun 12, 2025 - 04:42 UTC
Identified
Our vendor, Snowflake, is experiencing a service disruption. We sincerely apologize for any disruptions affecting our reporting systems, including reporting on Production Sheets.
We will provide additional updates as more information becomes available.