Zenput Service Disruption

Incident Report for Zenput

Resolved

The issue has been resolved. All services are operational.
Posted May 08, 2026 - 05:47 UTC

Investigating

We are currently experiencing a service disruption.

Our Engineering team is working to identify the root cause and implement a solution. A large amount of users may be affected.

We will send an additional update in 2 hours.
Posted May 08, 2026 - 05:08 UTC
This incident affected: Web Application, API, Task Generation, Reporting, Submission Processing, Labels Application, Mobile Application, Temp Monitoring and Notifications (Email, Push, SMS (Text)).