Zenput - Investigating Slow Response Times

Incident Report for Zenput

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 13:13 UTC

Investigating

We are experiencing reduced performance for some users. We are working to resolve this, but some users will experience poor performance while we fix this.
Posted Mar 15, 2025 - 13:04 UTC
This incident affected: Web Application, Task Generation, Submission Processing, Labels Application, Mobile Application, and Temp Monitoring.